top of page

Group

Public·53 members
Mstislav Osipov
Mstislav Osipov

Nctuns 6.0 Free Download For Windows 7



Problem: Ns makes my head hurt. Solution: Don't hit head against monitor. --> This page has moved and can now be found here. The below page will be maintained for reference to older versions.INSTALLATION PROBLEMSThis section will hold installation problems we've heard about andpossible fixes for them between releases.In general, these are fixes for ns/otcl/tclcl installationproblems. For Tcl/Tk-8.0 installation problems refer to Tcl/Tkinstallation info page.IMPORTANT: If you experience problem when building a ns dailysnapshot, you probably want to update your otcl and tclcl to the mostcurrent snapshot as well. Sometimes changes in ns will REQUIRE anupdated tclcl. If you are using nam with ns snapshot, it isrecommended that you update nam together with ns because ns mayprovide new visualization features which requires an updated nam. Categories of problems on this page: mailing-list-related problems general problems ns-allinone 2.28 2.27 2.26, 2.1b9, 2.1b8, 2.1b7, 2.1b6, 2.1b5, 2.1b4 ns 2.29, 2.28, 2.27, 2.26, 2.1b9, 2.1b8, 2.1b7, 2.1b6, 2.1b5, 2.1b4, 2.1b3, 2.1b2, 2.1b1, 2.0, 2.0b17 nam (nam problems have their own page) xgraph Tclcl 1.16, 1.0b13, 1.0b9, 1.0b8, 1.0b6. Otcl general, 1.0a3, 0.96 Intel Linux systems Other problems If a problem is not listed here, you may also want to search thens-users mailing list archives (how tosubscribe to the list, thearchives themselves). If something worked in an old verison of ns and no longer works, you can look at our CVSarchives (read-only) to see what we changed. (Thanks to the MASHproject for setting up and maintaining this service.) Mailing-list-related Problems For mailing-list-related problems, including subscribing, unsubscribing, and problems posting to the list, please see the mailing-list web page. General Problems Problem: I can't download ns from your web site. Work-arounds: First, many people have successfully downloaded ns (unless you're the first person to get a brand new release!). Odds are that the solution to problems downloading lie on your end: make sure that your browser isn't compressing or uncompressing it for you; try Netscape if you're using IE, or try another program to download like GNU wget; make sure you use (GNU) gunzip to uncompress it, not PKZIP. If these tricks don't help, you might also try getting it via FTP (from ) instead of HTTP (from ). If ftp'ing, try using a dedicated FTP client instead of a web browser, and make sure you transfer in BINARY mode, not TEXT. Problem: I can't subscribe or unsubscribe to the mailing list. I get error messages back like:>>>>> This is a multi-part message in MIME format.>**** Command 'this' not recognized.>>>>>>>>>> ------=_NextPart_000_0013_01C00841.7A1B9BA0>END OF COMMANDS Solution: Send simple text (ASCII) e-mail to the subscribe address, not MIME. Majordomo, the mailing list management program we use, can't handle MIME. Problem: My posts to the mailing list are rejected. I'm even subscribed to it. Solution: Please see the mailing-list FAQ. Problem: I was successful in installation, but I can't run the example script in in tutorial simple.tcl. When i tried to run it gives few errors like:use-scheduler: command not found attach-node: command not found...Solution: you need to run the script by issuing command: ns simple.tcl and you should add ns' directory to the environment variable PATH. Problem: Ok, but I still can't run simple.tcl under the ns/tcl/ex directory, it gives an error saying:couldnt execute nam: no such file or directory while executing "exec nam out.nam &". (Also, when I try typing the comamnd "ns simple.tcl", and I get the error "ns: command not found".)Solution: Well, you need to add nam' directory to theenvironment variable PATH or specify its location in the tcl script. (PATH is part of Unix, so if you're not sure how it works, please consult a local Unix expert or search the web on "unix PATH".) Problem: To fix another problem it says to "apply a patch file". What's that? How do I do that? Solution: To apply a patch file, get the the "patch" program (it ships with Linux and FreeBSD, or you can get it from ftp.gnu.org. Change into the directory with the source code you want to patch and type "patch Problem: I tried to apply a patch, but it failed. For example, I got messages like:[[email protected] ns-2.27]# patch Solution: Patches will succeed when applied to the same version of code against which they were generated. If the code has changed, you will get error messages like "hunk failed". Unfortunately, there is no general solution to failed patches. It could be that the underlying code changed so much the old patch will not work. But it could be that there were minor changes to the basic code and you could apply the patch manually. Some hints if you want to try manually applying a patch: If you want to try applying a patch by hand, you need to understand what you're patching, more or less. If you're trying to patch a Makefile and you have no idea what a makefile is, it's very possible you'll make an accidental error that prevents things from working. But don't fear, you can at least try, and you can always read the documentation about the make program and learn something! In the worst case you have to undo what you did. Also, although you will need some clue about what you're doing, you probably don't have to completely understand the code. If you try to manually apply a patch, you should study the patch manual page so you can understand the simple format that a patch file and a .rej file use. If you're not willing or able to manually apply a patch, you have one other alternative. A patch file takes original code (call it X-orig) and changes it into new code (call it X-new) by applying the differences described in the patch.Patches fail if the patch program cannot findwhat's described in the patch in X-orig.So an alternative to manually applying the patchis to find different original code.If you find the same original code the person whomade the patch used, you should get it to apply cleanly.So, for example, if a patch was generated against ns-2.26and it fails when applied to ns-2.27, you couldget rid of your copy of ns-2.27 and go get ns-2.26,then apply the patch to that older version.(Of course, this approach has other problems,since you may want other things that are only in ns-2.27.TANSTAAFL.) Problem: When I run validate or one of the test suites, I get these messages: warning: using backward compatibility mode and using backward compatible Agent/CBR; use Application/Traffic/CBR instead. Is my simulator broken? Solution: No, ns is not broken. These are warning messages output by the test suites, not errors. (However, if you get these messages from your scripts, we encourage you to move to the newer APIs.) Problem: I got the following error message during building OTcl creating cache ./config.cacheNo .configure file found in current directoryContinuing with default options...checking host system type... alpha-dec-osf4.0checking target system type... alpha-dec-osf4.0checking build system type... alpha-dec-osf4.0checking for gcc... gccchecking whether the C compiler (gcc ) works... yeschecking whether the C compiler (gcc ) is a cross-compiler... nochecking whether we are using GNU C... yeschecking whether gcc accepts -g... yeschecking for c++... c++checking whether the C++ compiler (c++ ) works... noconfigure: error: installation or configuration problem: C++ compilercannot create executables. Solution: Your c++ compiler (with exact name c++) does not seem to work. Check with your sytem admin. Problem: I get linking errors when building ns or nam likeUndefined first referenced symbol in fileet_tclobject/space/opt/ns-allinone-2.1b6/tclcl-1.0b9/libtclcl.a(Tcl.o)ld: fatal: Symbol referencing errors. No output written to nscollect2: ld returned 1 exit status*** Error code 1make: Fatal error: Command failed for target `ns' (or other symbols that begin with et_*). Solution: Build everything with gcc, don't mix gcc/g++ and cc/ld. (Insure that if you build any C++ code with g++ that you link with g++, and that they're the same version.) (These very confusing errors are from gcc. "et" is part of the run-time type checking. This code is generated at load time; gcc gets confused if you mix compilers.) Problem: I get errors like this when building ns-allinone: [[email protected] unix]# makegcc -pipe -c -O2 -Wall -Wno-implicit-int -fno-strict-aliasing -fPIC -I/home/vahid/Desktop/Temp/tk8.4.7/unix -I/home/vahid/Desktop/Temp/tk8.4.7/unix/../generic -I/home/vahid/Desktop/Temp/tk8.4.7/unix/../bitmaps -I/home/vahid/Desktop/Temp/tcl8.4.7/generic -DHAVE_UNISTD_H=1 -DHAVE_LIMITS_H=1 -DPEEK_XCLOSEIM=1 -D_LARGEFILE64_SOURCE=1 -DTCL_WIDE_INT_TYPE=long\ long -DHAVE_STRUCT_STAT64=1 -DHAVE_TYPE_OFF64_T=1 -DSTDC_HEADERS=1 -DHAVE_SYS_TIME_H=1 -DTIME_WITH_SYS_TIME=1 -DHAVE_PW_GECOS=1 -DTCL_NO_DEPRECATED -DUSE_TCL_STUBS /home/vahid/Desktop/Temp/tk8.4.7/unix/../generic/tk3d.cIn file included from /home/vahid/Desktop/Temp/tk8.4.7/generic/tkInt.h:21, from /home/vahid/Desktop/Temp/tk8.4.7/generic/tk3d.h:18, from /home/vahid/Desktop/Temp/tk8.4.7/generic/tk3d.c:16:/home/vahid/Desktop/Temp/tk8.4.7/generic/tk.h:96:29: X11/Xlib.h: No such file or directoryIn file included from /home/vahid/Desktop/Temp/tk8.4.7/generic/tkInt.h:21, from /home/vahid/Desktop/Temp/tk8.4.7/generic/tk3d.h:18, from /home/vahid/Desktop/Temp/tk8.4.7/generic/tk3d.c:16:/home/vahid/Desktop/Temp/tk8.4.7/generic/tk.h:573: parse error before "Window"... Solution: You don't have the development libraries for X11 installed on your system (see "X11/Xlib.h: No such file or directory"). Fix: install the X11 development libraries. How you do this is system-specific. In Redhat-like Linux distributions, make sure you have the X11 -devel packages installed. (In Fedora Core 2, installing xorg-x11-devel will fix this specific problem; in general you may need other -devel packages for libc, X11, and Tcl.) Problem: Validation under Windows does not work. Solution: As of ns 2.26, the windows port uses Cygwin which should substantly reduce validation errors. Please have a look at individual ns versions for specific details. The following information is way outdated. First, you need to download Cygwin, as of 2000-06-22 at version 1.1.2, which provides GNU binary utilities for the Windows platforms. You may also want to download pre-compiled Perl for Windows. After you've got all these tools, apply the following patch to ns/tcl/test/test-all-template1 to get around the \r\n problem:*** test-all-template1.orig Wed Jan 5 01:01:00 2000--- test-all-template1 Thu Jun 22 16:04:10 2000****************** 117,123 **** cp $datafile.bk $datafile mv $datafile.Z $directory/$t.Z else! gzip -dc $directory/$t.Z cmp -s - $datafile if [ $? = 0 ]; then echo Test output agrees with reference output else--- 117,123 ---- cp $datafile.bk $datafile mv $datafile.Z $directory/$t.Z else! gzip -dc $directory/$t.Z perl -ne 'print $_;' cmp -s - $datafile if [ $? = 0 ]; then echo Test output agrees with reference output elseNOTE:Some of the test suites will fail on win32 platform. As ofFeburary 26, 1999 snapshot of ns, the following test suitesfail: ./test-all-simple ./test-all-tcp ./test-all-red ./test-all-sack ./test-all-schedule ./test-all-red-v1 ./test-all-sack-v1 ./test-all-v1 ./test-all-vegas-v1 ./test-all-ecn ./test-all-manual-routing ./test-all-intserv ./test-all-webcache ./test-all-srm However, all of them failed because of floating point roundingdifferences on win32 and on unix. We will test current ns snapshots and update the resultshere. Thanks to Christian Joensson for his enthusiasm in keeping providingthe information and patches for many ns releases. IMPORTANT NOTE: The cygwin release 1.3.2 currently available (as of 07/2001), which we installed in win2000, doesn't seem to have a functional awk utility. A significant portion of the ns validation script uses awk, so we tried to replace awk with perl; but now the bash shell (another cygwin utility) didnot handle stdin/stdout correctly. So we were unable to validate the windows version (ns2.1b8a) in this platform. We welcome any suggestion from windows users to help solve this problem. Problem: The test suites and validation fail with errors like ns: _o3 cleanup file5 sackB4: Syntax error in file ../../bin/raw2xg atline 43, next 2 tokens "my("Syntax error in file ../../bin/raw2xg at line 59, next 2 tokens"translate_point("Syntax error in file ../../bin/raw2xg at line 94, next 2 tokens"translate_point("Execution of ../../bin/raw2xg aborted due to compilation errors.Can't locate 5.0010000000000003 in @INC at ../../bin/getrc line 4. while executing (where the key parts are "syntax error near my(" and "can't locate 5.001"). Solution: Get perl5 and/or make sure the programs in ns/bin are invoking perl5. Ns's configure checks for perl5, but apparently this check is not sufficient for many people's systems. Suggestions for improving the check are encouraged (it already works on our systems). Problem: Things built OK but don't run because of missing shared libraries (for example, you get the message "can't load library 'libotcl.so'" or "fatal: libotcl.so: can't open file: errno=2" [from Solaris]) or "libotcl.so can not open shared object file: No such file or directory". Solution: Many systems require that you do something special when installing new shared libraries. Shared-library loading is system-dependent, so consult the man page for ld(1) on your system. On many systems the program ``ldd'' can be used to diagnose shared-libary problems. A couple of hints: many systems require that you set the environment LD_LIBRARY_PATH to specify where to look for shared libraries. So if (let's say), you get the above error with otcl shared library (libotcl.so), you should append the path to your libotcl.so (which typically would be in the directory you have installed and built otcl) to the LD_LIBRARY_PATH macro in your .cshrc file. Other systems require that you run ldconfig when using new libraries. Problem: Ns (or otcl or tclcl) gets link errors when building with references to "dlopen" similar functions beginning with dl. Work-around: You need to manually add the library for dynamic linking to ns's Makefile. Look in the Makefile for the line LIB= and add your systems library for dynamic linking (typically -ldl). Solution: Unfortunately ns's autoconf support for dynamic linking isn't currently very good, and we can't test ns on all the platforms on which it's used. This configuration is done in ns/conf/configure.in.dynamic. If you can adjust the code there to correctly detect your system we'll be happy to add your patch to our sources. Problem:While building ns, it getscompiled but bails out with the following error message during linking:c++ -static -o ns \ tclAppInit.o random.o rng.o ranvar.o misc.o .... .... -lXext -lX11 -lsocket -lnsl -ldl -lm ld: fatal: library -ldl: not found ld: fatal: File processing errors. No output written to ns *** Error code 1 make: Fatal error: Command failed for target `ns' Solution:This error appears due to compiling with the static flag on. In static mode, ld selects only the shared object and archive files ending with .a, (unlike dynamic mode where files ending with either .so or .a are acceptable).Thus you will need to either configure with static option explicitly turned off with --disable-static, or edit ns makefile to replace the value "static"for the macro STATIC with blank (Dynamic mode is thedefault option). Problem: Ns is running out of memory and segfaulting. Solution: See the memory debugging tips section of the debugigng tips web page. Problem: I want to simulate ATM networks in ns. What should I do? Solution: If you just want to treat ATM as a 155Mb/s link for IP packets, you can get a pretty good approximation by, well, making a 155Mb/s link. Or a better approximation by accounting for ATM framing and using a 135Mb/s link. If you actually want to explore the interaction between ATM cells and IP packets, or MPLS, or something like that, you may have to implement it yourself or pack up a third-party package. One user (thanks L.) suggested in ns-users: umair/NS/doc/index.html(there's a mirror at: if you can't reach that.)It's for ns version 1, it's third-party, it's unsupported, you're onyour own.Deriving an ATM node class for ns-2 would actually be one of the fewcases where you'd expect incompatibilities between the derived classand everything else, and where the rest of the things ns simulates are_supposed_ to fail badly across it... would make it easier toimplement; less testing required! Problem: How do I properly reference the ns-2 simulatorin my papers ?. Solution: There are two answers to that question.If you want to cite the software itself, you can cite:S. McCanne and S. Floyd. ns Network Simulator. the manual:Kevin Fall, Kannan Varadhan, and the VINT project. The ns manual. If you want something published in a refereed location, [Breslau00a]Lee Breslau, Deborah Estrin, Kevin Fall, Sally Floyd, John Heidemann, AhmedHelmy, Polly Huang, Steven McCanne, Kannan Varadhan, Ya Xu, and Haobo Yu. Advances in Network Simulation. _IEEE Computer_, V. 33 (N. 5 ), pp. 59-67, May, 2000. Expanded version available as USC TR 99-702b at \url johnh/PAPERS/Bajaj99a.html. . Problem: What should I do if the ns executable has its modification time in the future when I re-start my machine after shutdown? Solution: We recommend that you talk to your local sysadmin since this indicates a clock difference between the file server and the client (this has nothing to do with ns). Problem: When using nam I get the following error: no display name and no $DISPLAY" Solution: Start the X server using startx at the prompt. Set the display environment variable using setenv DISPLAY my_hostname:0.0 (if you are using cshrc) or export DISPLAY=my_hostname:0.0 (if you are using sh or bash). This solution works for both cygwin and unix. ns-2.29 Problem: Some validation tests fail under Windows. This is a carry-over from ns-2.28 (see below).ns-2.28 Problem: Some validation tests fail under Windows. Solution:Currently, on Windows XP SP2 and Cygwin 1.5.12, only two test should fail -- newreno_rto_loss_ackf, and the new smac-multihop test-suite. Until now, if your research direction involves these features, it's best to use ns under some kind of Unix.




nctuns 6.0 free download for windows 7


Download: https://www.google.com/url?q=https%3A%2F%2Furlin.us%2F2ucxZ0&sa=D&sntz=1&usg=AOvVaw0oPeXstcV_IQIp2rKmTJd3


About

Welcome to the group! You can connect with other members, ge...

Members

bottom of page